Results 1 to 3 of 3

Thread: MGA hard starting sometime backfires

Discussions of MG Sports Cars

  1. #1
    Freshman Member
    Join Date
    Jul 2006
    Location
    new york, usa
    Posts
    8
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    MGA hard starting sometime backfires

    I have a 1958 MGA with SU carbs. It has become very hard starting. When it does turn over and start it begins like it is not running on all cylinders. Than it kicks in and runs fine. Takes a long time to idle before I can disengage the choke. While at idle if it drops below 900 RPM the engine cuts out and has to be restarted. When first started at times there is a backfire in the engine compartment not the exhaust tailpipe.

    Any suggestions greatly appreciated

    Thank you

  2. #2
    Jedi Trainee WA1KWA's Avatar
    Join Date
    May 2007
    Location
    Tewksbury, Massachusetts
    Posts
    291
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Re: MGA hard starting sometime backfires

    I'd first check timing; both ignition & cam timing. Possibly the cam chain tensioner has failed?

    But first, Ignition points being way out of adjustment can affect ignition timing & cause this also. Check your points dwell.

    Colin

  3. #3
    Senior Member
    Join Date
    Feb 2007
    Location
    Colorado
    Posts
    97
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Re: MGA hard starting sometime backfires

    Are you sure the choke is working properly? Although you are pulling out the choke knob, it isn't doing any choking?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •