Results 1 to 2 of 2

Thread: TR3A hiccup

Discussions of Triumph motor cars

  1. #1
    Senior Member Anthony_S's Avatar
    Join Date
    Jul 2011
    Location
    Menomonie, WI 54751
    Posts
    93
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    TR3A hiccup

    So the last few times I have driven the TR I have noticed as I accelerate in the upper speed range from 60-70 the engine seems to have a slight hiccup. Instead of a smooth acceleration it will be gaining speed then have a slight miss, skip or hiccup....best way I can describe it. It isnt continuous either. Like it loses a bit of power, maybe something is sticking or I don't know really. Any thoughts on this. I know I need to do a full tune-up on the engine which will probably make all the difference but I am curious what this may be.

    Thanks
    Anthony
    1960 TR3A TS58470 L

  2. #2
    Yoda Gliderman8's Avatar
    Join Date
    Jun 2008
    Location
    PA
    Posts
    8,934
    Thanks Thanks Given 
    16
    Thanks Thanks Received 
    58
    Thanked in
    55 Posts

    Re: TR3A hiccup

    Had a similar problem with my TR6... I replaced the coil and problem solved.
    Elliot
    Central PA
    1973 TR6 Damson Plum / Biscuit interior, HVDA 5-speed, Good Parts Hubs
    1976 TR6 White/Biscuit interior SOLD
    Nostalgia isn't what it used to be.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •