Results 1 to 4 of 4

Thread: 1997 Vanden Plas X300 ,Help With Turn Signal Blowing Fuses

Discussions of Jaguar Automobiles of all styles

  1. #1
    Freshman Member
    Join Date
    Jan 2020
    Location
    Chattanooga ,TN USA
    Posts
    3
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    1997 Vanden Plas X300 ,Help With Turn Signal Blowing Fuses

    • Hello fellow jaguar enthusiasts I have a 1997 Vanden Plas that keeps blowing the front passenger side fuse for the right side flasher , the bulb out indicator stays on when the fuse is blown and when I put a new one in the bulb out indicator still comes on when the brake pedal is pressed and the right side flasher is used. No brake lights are blown no flashers are blown but the indicator still comes on and use of the right side flasher blows the fuse in about ten minutes of use. Any and all suggestions would be helpful.








  2. #2
    Luke Skywalker LarryK's Avatar
    Join Date
    Mar 2007
    Location
    Millstadt, IL
    Posts
    1,972
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    16
    Thanked in
    16 Posts

    Re: 1997 Vanden Plas X300 ,Help With Turn Signal Blowing Fuses

    Might check right side ground and trace wires thru fender for cuts or cracks. Old enough for wires to chaff. Find a wiring schematic and see where everything comes together.
    Larry K
    58 Jag 3.4 MK 1 auto under restoration, 57 Jag 3.4 MK1 manual ,
    03 Cooper S, 2011 Cooper S Countryman, 2011 Land Rover LR4 HSE LUX, 1964 Valiant V200
    Also had , 68 Cortina 1600E, 64 Spit 4 & 80 1500, 73 GT6 3, 71 XJ6, 79 XJ6, 86 XJS V-12, 53 XK120 OTS.

  3. #3
    Freshman Member
    Join Date
    Jan 2020
    Location
    Chattanooga ,TN USA
    Posts
    3
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Re: 1997 Vanden Plas X300 ,Help With Turn Signal Blowing Fuses

    Thank you very i will try that.
    Regards. JL

  4. #4
    Yoda TOC's Avatar
    Join Date
    Jun 2008
    Location
    Floe Ice, Antarctica
    Posts
    6,344
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    24
    Thanked in
    24 Posts

    Re: 1997 Vanden Plas X300 ,Help With Turn Signal Blowing Fuses

    It has been a LONG time since I dove into one of those.
    But:

    Isn't the inside of the assembly a circuit board?

    If it takes that long to blow the fuse, and you have a dead bulb indication....I'd be looking at the socket and circuit board carefully for corrosion, burn marks, et cetera.

    If this was the MG or TRiumph forums, I'd say replace the coil.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •