Results 1 to 4 of 4

Thread: busy tach on 1979 MGB at 75 mph

Discussions of MG Sports Cars

  1. #1
    Senior Member boxofparts's Avatar
    Join Date
    Apr 2006
    Location
    Petoskey Michigan
    Posts
    76
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    busy tach on 1979 MGB at 75 mph

    Any tips on fixing this busy tach on my MGB?

    https://studio.youtube.com/video/-_jbLrLVex0/edit

  2. #2
    Luke Skywalker
    Join Date
    Apr 2005
    Location
    Giswil, CH & Fallbrook the Avo Capital, USA
    Posts
    1,590
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    8
    Thanked in
    8 Posts

    Re: busy tach on 1979 MGB at 75 mph

    Tacho picks up a pulse via the dizzy/coil. Would start there and look for loose or dirty connections.
    You may find that the problem is in the dial.
    Cheers,
    D.
    "If it's got t*ts or tyres, you've got problems"
    www.englishmotorsatfairbrook.org
    TVR Car Club North America Southwest Regional Organiser

  3. #3
    Jedi Hopeful
    Join Date
    Jul 2018
    Location
    Austin TEXAS
    Posts
    145
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    6
    Thanked in
    6 Posts

    Re: busy tach on 1979 MGB at 75 mph

    Quote Originally Posted by Grantura_MKI View Post
    Tacho picks up a pulse via the dizzy/coil. Would start there and look for loose or dirty connections.
    You may find that the problem is in the dial.
    At 75MPH you are probably spinning close to 4000 RPM (unless you have an OD transmission in which case more like 3500) - could you be experiencing a missfire which just happens too quick to notice but causes the tach to drop, then pick back up, with the momentum of the needle causing the wild swings?

  4. #4
    Senior Member boxofparts's Avatar
    Join Date
    Apr 2006
    Location
    Petoskey Michigan
    Posts
    76
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Re: busy tach on 1979 MGB at 75 mph

    I thought about misfire but the engine is pretty smooth. I need to check wires to make everything is clean and well connected. The service manual states there is a loop of wire in the tach. I wonder if I put a loop of wire around a magnet like I have on some of my power cords? Toroid choke?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •