Results 1 to 2 of 2

Thread: I screwed up - Bosch VE pump.

This is a forum for discussing cars that are not British. Discuss anything from Mazda to Corvettes or anything in between here.

  1. #1
    Luke Skywalker
    Join Date
    Nov 2005
    Location
    Jerusalem, Israel
    Posts
    1,626
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    I screwed up - Bosch VE pump.

    Well to try and stop a big fuel leak on my Nissan Serena. (LD23 diesel Engine) I eased off the back of the pump to replace the o-ring between the aluminium body and the cast iron head (part where the high pressure pumps are and the outlets to the injectors. THAT part went OK I think (nothing escaped and it all went together easily)

    but now I have 2 problems:
    1 the pump won't prime.

    2 Trying to get to the head I took off the accelerator and top plate but now the "idle mixture" potentiometer may not be set properly - WHAT is an Idle mixture control on diesel engine? diesel has the air fully opened and all control is from the amount of fuel injected. Any ideas?
    Attached Images Attached Images

  2. #2
    Luke Skywalker
    Join Date
    Nov 2005
    Location
    Jerusalem, Israel
    Posts
    1,626
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Re: I screwed up - Bosch VE pump.

    OK I finally got it to prime and realized that I put the accelerator arm on a bit rotated so it wasn't opening the throttle at all. Now it starts. warm and cold idle are high but that is just two screws, probably full power will be a bit low. That will be a pain since it has a tamper nut.

    Still trying to figure out what the potentiometer does.. (doesn't seem to do much actually)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •