Results 1 to 4 of 4

Thread: MGA turn signals

Discussions of MG Sports Cars

  1. #1
    Freshman Member
    Join Date
    Jul 2006
    Location
    new york, usa
    Posts
    8
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    MGA turn signals

    Need help on getting front turn signals to work on my 1957 MGA. Ran over metal debris on the road and it cut the wires for my right front wiring. Connect the obvious cut wires but turn signals do not work. Only have two wires competing out of parking/turn signal, how do I connect the ground. Also cannot find the ground on the right front side. I feel the ground is the problem but any other advice is appreciated. Thank you
    Attached Images Attached Images

  2. #2
    Great Pumpkin DrEntropy's Avatar
    Join Date
    Sep 2005
    Location
    Elsinore, DK
    Posts
    33,112
    Thanks Thanks Given 
    33
    Thanks Thanks Received 
    67
    Thanked in
    66 Posts

    Re: MGA turn signals

    Ground should be established through the chassis. No "ground wire" per se. To determine if the bulb holder isn't getting good connection, run another wire from a solid point on the chassis to the bulb holder shell and see if the lights come on.
    '64 MGB, '67 Lotus Elan S-3 DHC,'69 Lotus Elan +2
    '78 Alfa Romeo Spider-undergoing surgery: O=\*/=O
    '84 300D Turbo-"Diesela"-Now my Daily: Oo|≣|oO
    '02 Toyota Camry- SWMBO's 'new-to-her' Daily. <sigh>
    Chaos & Mayhem PTY, LTD..C.I.O. & Floor Sweepervisor

  3. #3
    Freshman Member
    Join Date
    Jul 2006
    Location
    new york, usa
    Posts
    8
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Re: MGA turn signals

    Two wires coming from the turn signal on right hand side. When I turn the lights on one wire is hot the other wire no power. I disconnected the no power wire to test and it did not effect the light being on. When I switched the turn signal on my test light connected to the non power wire blinked like a turn signal. When I reconnected the wires no turn signal light blinked but the test light still blinked. Since the left turn signal also does not work I don’t think it’s the bulbs. Also can’t find the ground doesn’t seem to be on the right side. Difficult to get at because of the radiator etc. any suggestions greatly appreciated.

  4. #4
    Freshman Member barneymg's Avatar
    Join Date
    Jan 2020
    Location
    North America at large (previously Naperville, Ilinois)
    Posts
    7
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    1
    Thanked in
    1 Post

    Re: MGA turn signals

    MGA front corner lamps should have three wires (including Black ground wire), but some replacement lamps in recent years only have two wires. Moss recently changed theirs to three wires.

    With no ground wire, the fixture has to find ground through the mounting screws to the fender, kind of iffy once the rust bug sets in.

    The front lens comes off with a push and twist anti-clockwise. Connect a jumper wire from the lamp shell to ground on the bumper to see if it lights up. Parking light power is red wire. Turn signal power is the striped wire. Check continuity from harness to lamp internal contacts (and the bulb of course).
    Barney Gaylord - 1958 MGA with an attitude
    http://MGAguru.com - barneymg@mgaguru.com

    Please do not leave a PM for me on the forum server (expect long delays).
    If you want to contact me privately, please use my personal email link above.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •