Search:

Type: Posts; User: N233TX; Keyword(s):

Search: Search took 0.00 seconds; generated 46 minute(s) ago.

  1. Replies
    6
    Views
    911

    Re: Need brake bleeding advice

    Thanks to all for your suggestions. After repeated bleeding I now have a nice pedal and no visible leaks. Post-maintenance drive incident-free. Took patient petal pusher out to dinner. I had...
  2. Replies
    6
    Views
    911

    Need brake bleeding advice

    1975 Midget 1600 Installed new brake master cylinder as old one had an unfixable leak. Both my Midget shop manuals *did not*specify bench bleeding the new master, a chore I chose to avoid since I...
  3. Replies
    6
    Views
    888

    Re: Electrical Troubleshooting Advice Needed

    Mission accomplished. Three hours with test light, multimeter and Deoxit has all necessary functions operative. Bullet connectors were not too gooped up so the Deoxit did the trick. Had to sand...
  4. Replies
    6
    Views
    888

    Re: Electrical Troubleshooting Advice Needed

    Thank you for that response. Been there before for that drill; was hoping for a targeted quick fix, but alas... I have had good luck using a product called Deoxit spray on fussy connectors on...
  5. Replies
    6
    Views
    888

    Electrical Troubleshooting Advice Needed

    '75 Midget 1500 Starts and runs fine but turn signals went out recently and checking found most everything, save headlights, was a no-go. Stoplights are on bright anytime battery is connected. ...
  6. Replies
    5
    Views
    744

    Re: Temp Gauge No-Go

    Problem solved...apparently. I went through the drill of grounding the sending unit in the hot water and the needle moved more toward normal than before. Just curious, I pulled the ground wire off...
  7. Replies
    5
    Views
    744

    Re: Temp Gauge No-Go

    OK, above test showed no needle movement and gas gauge performs perfectly. Dropped the sender in near-boiling water and needle moved off peg but only maybe 1/8" closer to the 6 o'clock position than...
  8. Replies
    5
    Views
    744

    Temp Gauge No-Go

    Well, somehow the car (1500, '75 model) being down for 6 weeks for brake work kayoed the temp gauge. No movement off the cold position. First order of business will be to disconnect the sender and...
  9. Replies
    11
    Views
    1,901

    Re: Need Brake Bleeding Help

    Thanks y'all. O-rings that went into the compensating valve were in the rebuild kit from Moss so they should be brake fluid compatible. Bleeder valves were inspected and found OK. Gonna check that...
  10. Replies
    11
    Views
    1,901

    Re: Need Brake Bleeding Help

    OK, weather delays and back to the problem... Took poster advice to inspect and rebuild the switch assembly. It was very clean but cleaned as per and installed new o-rings. Figured it would be a...
  11. Replies
    11
    Views
    1,901

    Re: Need Brake Bleeding Help

    Floor is dry. Will proceed with suggested fix. Never heard of an air lock. Would that create the symptoms noted? e.g. inability to either extract or inject fluid?
  12. Replies
    11
    Views
    1,901

    Need Brake Bleeding Help

    '75 Midget 1500 Fluid mysteriously lost from system (none on floor or apparent mess on wheels.) Proceeded to bleed as per manual. Cannot get fluid to either flow into bleeder jar or suck back out...
  13. Replies
    15
    Views
    4,299

    Re: Runs Rough Under Load

    New wires on the way. Appreciate the explanation. Will temporarily install bad coil after wire installation to see if this was, indeed, the cause.

    Still learning about this car after 32 years...
  14. Replies
    15
    Views
    4,299

    Re: Runs Rough Under Load

    It was the coil. Popped on a spare (removed from car in last century) and the problem went away. Astounding. My only experiences with coil failure were normal ops followed by completely nothing...
  15. Replies
    15
    Views
    4,299

    Re: Runs Rough Under Load

    Thanks for suggestions. Will try all...one at a time. Starting with the coil. Will post solution when and if one is determined. Timing set to US spec.

    I have heard a different jet in the...
  16. Replies
    15
    Views
    4,299

    Runs Rough Under Load

    Midget 1500/Weber Carb Runs great at all RPM in shop. Intermittent rough running under load, especially uphill. Stumbles big-time under quick acceleration. Timing, points, rotor, valves,...
  17. Replies
    12
    Views
    982

    Re: Miss when when accelerating

    Re: Original post... Found the accelerator pump adjustment. Adjusted. Problem solved. Thanks, y'all.

    Jim
  18. Replies
    12
    Views
    982

    Re: Miss when when accelerating

    I'm thinking you were right about the acc pump. Upon close examination, there isn't enough cable "pull" to engage the acc pump at WOT on the footfeed and still release back to idle. Weber manual...
  19. Replies
    12
    Views
    982

    Re: Miss when when accelerating

    OK, sounds like I need to get into the carb. Tonite maybe tomorrow. Thanks.
  20. Replies
    12
    Views
    982

    Re: Miss when when accelerating

    Weber installed about 2-3 years ago. Car driven bi-weekly. Since certain equipment long since removed, timing is set at the British spec...can't remember what that was. Car runs *great* except for...
  21. Replies
    12
    Views
    982

    Miss when when accelerating

    First post. '75 Midget, 1500 engine, owned since '81. Mileage somewhere south of 50,000...odo/speedo inop. Weber carb installed less than 500 miles ago. Runs great with one exception: When I stomp...
  22. Thread: 1500 Fuel Pump

    by N233TX
    Replies
    5
    Views
    860

    Re: 1500 Fuel Pump

    Yessir, it is a downdraft. I plan to fabricate a cover plate for the stock pump and mount the boost pump FWF in an insulated box to hopefully hush it up some. I have a regulator if needed. The...
  23. Thread: 1500 Fuel Pump

    by N233TX
    Replies
    5
    Views
    860

    Re: 1500 Fuel Pump

    Doug, 'preciate the lead. Will test and rig up Facet if indicated.

    Jim
  24. Thread: 1500 Fuel Pump

    by N233TX
    Replies
    5
    Views
    860

    1500 Fuel Pump

    The engine-driven fuel pump on my '75 Midget seems anemic. Engine runs OK but stumbles when you jab the throttle at lower RPMs. The amount of fuel entering the clear plastic filter upstream of the...
Results 1 to 24 of 24