• twas_brillig

    There is no available content written by twas_brillig
  • Recent Articles

  • Recent Forum Posts

    AUSMHLY

    Re: Wheel Tire Camber

    Thank you Steve and Randy.
    Steve, if that's the issue, it seems like an eazy fix, although I may have to continually use this spray lubricant.

    AUSMHLY Today, 11:37 AM Go to last post
    mxp01

    Re: Sump Installation

    Thanks Larry

    mxp01 Today, 11:36 AM Go to last post
    Mag9

    1966 bj8

    Hi All, Just sold my 1957 MGA to a fellow in France and purchased a nice Austin Healey BJ8
    I have had a number of British cars over the years...An

    Mag9 Today, 11:32 AM Go to last post
    Gliderman8

    Re: Air-bag test device...

    Only the undertakers.

    Gliderman8 Today, 11:32 AM Go to last post
    TCMapotherIV

    Re: Pinto Engine In Bugeye

    Do you know what this car went for? I'm curious because I just bought a 1960 Bugeye that was just restored with a souped up 2.0 Pinto engine. My hood

    TCMapotherIV Today, 11:22 AM Go to last post
  • Recent Blog Posts

    Faithraven

    78 MGB won't start, all new ignition, all checks out?

    Hello everyone! I'm stumped??

    I need help with my 78 MGB


    I have the following:

    [FONT=Verdana]WEBER 2bbl. carb. (I Have a 40,000 volt Flamethrower...

    Faithraven 01-17-2020 04:49 PM
    Walker sim

    Fuses

    Hi All,
    When, on my Healey 100 BN1, (with a BN2 gearbox with OD), I switch the OD on, both the slow blow 50A AND 35A fuses blow. Any ideas why?

    Cheers
    Wally Simpson

    Walker sim 01-12-2020 06:40 PM
  • Twitter