View RSS Feed

Faithraven

78 MGB won't start, all new ignition, all checks out?

Rate this Entry
Hello everyone! I'm stumped??

I need help with my 78 MGB


I have the following:

WEBER 2bbl. carb. (I Have a 40,000 volt Flamethrower coil with Pertronix LU-147a igniter upgrade in a LUCUS 45DE4 distributor.) It does have a ballast resistor installed next to the coil. but I not sure it needs it or how to correctly bypass it? I currently have all connections tight and clean.

**(Distributor/coil fully connected and Key off, I have 78.6 ohms on Negative side if it matters?

With the primary and secondary readings, first testing +to - posts (Bench test), I have 3.2 ohms and center to pos. or neg. posts, I have 9.5 with meter set at 200k checking from center to neg or positive posts.

I replaced the timing chain, gears, and tensioner In September 2019. (Gears were installed with the fact that it doesn't tell you its actually cylinder #4 TDC) Ran that night, next day, nothing since???

I went back to mechanical step 1 then the following...

I have checked the valve lash at tight 13mm, tight 12mm gap.(cold won't start yet).

I have made sure distributor rotor is facing #1. Static timing checks out (set while TDC #1 piston is up).

I have spark going through coil wire when cranking, and a flashing spark at the #1 plug wire while cranking.

Wires, plugs, cap, and rotor, are new.

Fuel and choke? Pulled spark plugs after cranking, wet with fuel. Unhooked and plugged fuel line and tried using starting fluid in case of bad gas,... Nothing but an occasional sputter or a brief backfire out exhaust. I incrementally turned distributor both ways and either got a slight back run or again, pops out exhaust or carb?

Still won't indicate any attempt to run? Ignition switch is new and I have continuity from starter connection to coil?

ANY IDEAS??

Thanks, Willis

Submit "78 MGB won't start, all new ignition, all checks out?" to Digg Submit "78 MGB won't start, all new ignition, all checks out?" to del.icio.us Submit "78 MGB won't start, all new ignition, all checks out?" to StumbleUpon Submit "78 MGB won't start, all new ignition, all checks out?" to Google

Categories
Uncategorized

Comments

  1. RHWins's Avatar
    I killed a pertronix by not using a ballast on the line from the coil to the distributor. Check the ohms specs on your coil with the specs for the Pertronix. One of the wires (white/bk) is supposed to include proper resistance but... You might replace the Pertronix with points and condenser to see if that works, for purposes of elimination.
  2. RHWins's Avatar
    Might you have the spark plug wires out of sequence?
  3. Faithraven's Avatar
    Quote Originally Posted by RHWins
    I killed a pertronix by not using a ballast on the line from the coil to the distributor. Check the ohms specs on your coil with the specs for the Pertronix. One of the wires (white/bk) is supposed to include proper resistance but... You might replace the Pertronix with points and condenser to see if that works, for purposes of elimination.
    That was it!

    Probably for numerous reasons but... ground inside was loose. Left the key on once for an hour as well. Lol

    Thank you. Warranty was honored.