• Turn signals - from working fine to gone!

    My newly acquired 78 MGB had everything working a month ago. Since then I have replaced both clutch cylinders and now the turn signals and four way flashers are gone. The fuses are fine and I pulled out the flasher and replaced it with one that was with the car in a bag so Iím not sure if it is old or new. Anyway, Iím new to the British car scene and would appreciate advice on a check list to isolate and fix this problem. Please help. 🤣
    Comments 1 Comment
    1. vette's Avatar
      vette -
      Hello, My first idea is that you should move this question to the MG forum section of this web site. There are plenty of MG people there.
      But I can give a few things to look at since I have worked on many MGs. On the B's the connectors under the dash sometimes get disturbed and lose connection so make sure they are well seated. Also if you separated any of the connectors especially some under the dash then check them again because the plug configurations are so close that they can be intermixed. look closely at the wire colours to make sure you are putting the right plug to the right connector. Since you changed your master cylinders it is possible that you loosened some connections or reconnected them wrong. Go luck and talk to the boys and girls on the MG forum. Just hit forum buttom and scroll down.
  • Recent Articles

  • Recent Forum Posts

    HealeyRick

    Re: Cold Air Bilge Blower update

    Not Healey, but MGB, but gives the idea of what people do for inner fender vents: http://forum.britishv8.org/read.php?8,50660

    HealeyRick Today, 02:05 PM Go to last post
    Pythias

    Re: Speedo drive gear

    There ARE different drive gears available.(at least for the DATSUN tranny) Paul A. had someone in Portland Oregon (a speedometer shop I believe, but can't

    Pythias Today, 01:46 PM Go to last post
    Silverghost

    Re: 5.5 floppy drive

    Would a floppy disk to hard drive converter be something made by Viagra? C'mon.....someone had to say it, might as well be me.....

    Silverghost Today, 01:37 PM Go to last post
    PAUL161

    Re: Getting even in parking lots...

    Love that movie!

    PAUL161 Today, 12:42 PM Go to last post
    FlyingCat

    Re: Electric fan

    I have a 1980 Spitfire, too, and had the same problem with the fan. Fan worked when wired directly, but when wired through the relay switch, not at all.

    FlyingCat Today, 12:24 PM Go to last post
  • Recent Blog Posts

    Madflyer

    Madflyer

    As a new member and long time TR owner of a few TR's. I fine the same topics come up time and time again. Here are three I like best; What tire is best and where do I get them and what do they cost....

    Madflyer 07-06-2020 10:27 AM
    Factoryman2000

    Adding AC to BN7 Healey

    Hi,recently visited a well regarded restoration shop and saw the install of AC system on an MGB. The installer had ordered a dual Compressor pulley, and the original v belt now drove waterpump, Fan...

    Factoryman2000 07-05-2020 04:17 PM
    commonground

    New member from california. Bring back the herald

    I am pursuing the creation of a sixties Triumph Herald. Nearly unknown in the USA.. I had one here in the late 60s. Loved the car handling and packaging. Hated very poor British parts quality and...

    commonground 07-05-2020 02:11 PM
    Madflyer

    Madflyer

    Good morning all as a new member yesterday I found BCF quite good and as a long time TR owner, I still learn more each day and yesterday a great day for sure. I added my inputs to a number of post...

    Madflyer 07-05-2020 12:13 PM
    Ale

    Just bought 1975 Triumph TR6 that has sat for last 25 years

    Hello I am a new member, I was directed to the form by a friend. I have recently purchased a TR6 that hasnít moved or started it the last 25 years. Everything under the hood held up nicely and...

    Ale 07-03-2020 07:35 PM
  • Twitter