• Turn signals - from working fine to gone!

    My newly acquired 78 MGB had everything working a month ago. Since then I have replaced both clutch cylinders and now the turn signals and four way flashers are gone. The fuses are fine and I pulled out the flasher and replaced it with one that was with the car in a bag so Iím not sure if it is old or new. Anyway, Iím new to the British car scene and would appreciate advice on a check list to isolate and fix this problem. Please help. 🤣
    Comments 2 Comments
    1. vette's Avatar
      vette -
      Hello, My first idea is that you should move this question to the MG forum section of this web site. There are plenty of MG people there.
      But I can give a few things to look at since I have worked on many MGs. On the B's the connectors under the dash sometimes get disturbed and lose connection so make sure they are well seated. Also if you separated any of the connectors especially some under the dash then check them again because the plug configurations are so close that they can be intermixed. look closely at the wire colours to make sure you are putting the right plug to the right connector. Since you changed your master cylinders it is possible that you loosened some connections or reconnected them wrong. Go luck and talk to the boys and girls on the MG forum. Just hit forum buttom and scroll down.
    1. iceman's Avatar
      iceman -
      Check grounds at bulb location. Do you have a wiring diagram to run a visual check of your wiring?
  • Recent Articles

    DrEntropy

    To Replace with Period Correct or Upgrade?

    Some Thoughts on LBC Originality vs. Reliability
    by DrEntropy


    The discussions of originality as in contrast to reliability is an old one. For the most part they seem mutually exclusive. Purists want to enter concourse events and win awards for their examples,... read more
    DrEntropy 01-05-2021, 01:20 PM

    Categories:

    Restoration/Car Care 
  • Recent Forum Posts

    Frank Canale

    Re: front body mounts

    Thanks Steve, I trust yours and John’s comments to my original post and that made my decision that much harder. Sometimes you have to get off the

    Frank Canale Today, 11:14 AM Go to last post
    sp53

    Re: front body mounts

    Looking great Frank yes all those panels look great. I went through that problem and did not try your method of re-holing it. I wish I would have. Heck

    sp53 Today, 10:41 AM Go to last post
    sp53

    Re: Emergency Brake Adjustment

    John can you post the picture when you get it? I want to play too. I know how I struggle with the technology, and I think Dick has a couple years on me.

    sp53 Today, 10:29 AM Go to last post
    vette

    Re: Overdrive Failure

    On my Bj7 the clicking sound, with engine off and moving the shifter from neutral to the right side of the gate, is the sound of the switch on the shifter

    vette Today, 10:10 AM Go to last post
    ed_h

    Re: Fixing the intake manifold

    A little re-shaping probably can't hurt.

    Ed

    ed_h Today, 10:10 AM Go to last post
  • Recent Blog Posts

  • Twitter