PDA

View Full Version : Spitfire MKII Spitfire brake light pblms



DomCasual
08-12-2012, 09:55 AM
'65 Spitfire, MKII brake lights [both sides] don't work, although the tail lights do, as do the parking lights front and back, both sides.

I suspect a switch issue but Haynes does not cover trouble shooting the brake lights except bulb replacement.

Any suggestions would be appreciated...

Peter in Charlottesville

Andrew Mace
08-12-2012, 10:38 AM
Troubleshooting is pretty simple: with ignition on, jump the two terminals on the pedal switch, or remove the two wires and jump them together. If the brake lights come on, the switch is likely bad. If they don't, then you need to see if you get power from that circuit to the lamps themselves.

3798j
08-12-2012, 10:52 AM
Those brake switches are notorious (from my experiences anyway) for sticking in the "off" position. And, no they can't seem to be freed from sticking.

TR3driver
08-12-2012, 05:37 PM
jump the two terminals on the pedal switch, or remove the two wires and jump them together.
Meaning to install a jumper wire that temporarily connects the two wires together. One easy way to do that is to have a set of these https://www.radioshack.com/product/index.jsp?productId=2062661 on hand. IMO they are a required tool for anyone who drives an old car.

(HF sells a similar set for a few dollars less, but I don't recommend them. The boots are so hard and slick that things slide around when you try to open the clips.)

Note that the key must be on, and the 'green' fuse good, for the brake lights to work.