PDA

View Full Version : TR6 TR6 contact breaker points - closing



Alfasudcrazy
02-28-2005, 06:01 PM
My TR6 is going like a gem of late except for one anoying thing. The contact breaker points close after doing about 15 miles. Adjust them again and it s fine until I have done another 15 miles?
I think I tighten them up as tight as its safe to do - what could be causing it. I have replaced the points a few times but that does not seem to cure it - can anyone help? /ubbthreads/images/graemlins/cryin.gif

Geo Hahn
02-28-2005, 06:06 PM
Are you using any lubrication on the distributor cam? The cheap (usually red) plastic bit that rides on the cam can wear if the cam is hot and dry. I use a bit of assembly lube there though there is a purpose made product just for that spot (they used to give you a little capsule of it in each box of points... but then they used to give you toy cars in your box of cereal too).

Also, you might simply not be getting the points tightened down enough though really it doesn't take a lot to hold them in place.

trrdster2000
02-28-2005, 06:48 PM
Alfasudcrazy, I have seen this twice and both times it was not the points closing but the plastic bit that rides on the cam in the distributor melting and the problem was a hot coil for an American car from AutoZone or such. If you still have a set of points you took out, have a look and see if the litle bit is shorter than a new set. The Lucas Sport Coil will fix that. Wayne

SkinnedKnuckles
02-28-2005, 10:10 PM
Sounds like you may be a candidate for a breakerless ignition system...