PDA

View Full Version : TR4/4A TR4A e-brake button keeps falling off



Alec
03-28-2012, 07:01 PM
What gives? The rubber(?) e-brake button one pushes to set the e-brake is loose and keeps falling to the floor. It looks as though it is supposed to be screw in fit to the pawl spring, but the attachment hole in the button seems a bigger now so the button won't stay put, and other than crazy glue I can't see a fix.
Any solutions would be welcome. As a matter of interest, does anyone have a machined version of the button - I thought I saw a posting picture with one having an aluminum button??
Cheers,
Alf

Stinger
03-28-2012, 08:15 PM
We just repaired ours on our TR4A and it was made of plastic. Buy some JB Weld epoxy and it will stay on forever!

Alec
03-29-2012, 02:00 PM
Many thanks - I guess "glue" is the only solution. I might try and machine a metal version and use JB weld on that. Thanks again

Darrell_Walker
03-29-2012, 02:04 PM
I have a metal button on mine. The car had no button when I got it, and I'm pretty sure the replacement came from TRF. But that would have been about 20 years ago....

Alec
03-29-2012, 02:23 PM
Darrell, by any chance do you recall if the centre of the button was drilled and tapped (thread size?)or just drilled?
Cheers.

Darrell_Walker
03-29-2012, 02:31 PM
Darrell, by any chance do you recall if the centre of the button was drilled and tapped (thread size?)or just drilled?
Cheers.

No, I don't recall how it attached. I just went to check, and I wasn't able to unscrew the button by hand, I'm reluctant to use a tool of any kind on it.

Alec
03-29-2012, 04:20 PM
Thanks, thats OK - appreciate the input.