PDA

View Full Version : 1500 Clutch hose question



JPSmit
05-25-2011, 01:32 PM
Mark (Abarth69) thinks I am messing with him so, I need your help.

1500 clutch hose is red, translucent, slightly plasticy looking and friction fit over the metal ends right?

Mine is (from VB) but it matched the one that was there.

please confirm.

bthompson
05-25-2011, 02:30 PM
Confirmed with Nigel, (unless he's had the same replacement Triss has.) Red, translucent, plastic, not very flexible, and as far as I can tell, friction fit.

Jer
05-25-2011, 02:32 PM
I belive that in Horler's book there is a picture that shows the red tranlucent'y thing as well....

aeronca65t
05-26-2011, 05:35 AM
Yes. Clutch hose on 1500 cars look like it belongs in a fish aquarium.

Morris
05-26-2011, 09:25 AM
Are the threads on the fittings SAE? Or are they some funky British thread? I am in the process of replacing my clutch master and I was kicking around the idea of having a "real" hydraulic cable made up.

abarth69
05-26-2011, 03:24 PM
Okay JP

No wonder MG went the way of the dinosaur.

Cheers

Mark

JPSmit
05-26-2011, 04:06 PM
Are the threads on the fittings SAE? Or are they some funky British thread? I am in the process of replacing my clutch master and I was kicking around the idea of having a "real" hydraulic cable made up.

I Believe they are SAE, others?

JPSmit
05-26-2011, 04:08 PM
BTW - I will be putting a hose clamp on the bottom at the earliest convenience - Mark you're right, friction fit is a dumb idea, just hadn't thought of it before.

Morris
05-28-2011, 11:55 PM
If you haven't already... use a fuel injection clamp. They are much stronger and more reliable than your typical worm screw style water hose clamps.