PDA

View Full Version : 150 CD stromberg spraying gas HELP



tomgt6
08-29-2004, 11:13 PM
I have a 1970 GT6 with dual cd strombergs. I broke down the other day and wouldn't run right. I figured it was a carb issue. When I took the filter cover off the one carb was spraying gas out a hole on the right hand side at about 2 oclock. I rebuilt the carbs and found a diapham ribbed in this carb. I put them back on and the car started and ran fine for a couple of minutes and then the gas started to spray again out of the same carb. If I stick my finger over it the car still runs fine and no gas spray.

So what is it. Did I not get the float set right or what. Everything else looks ok and the only thing I can guess is that the float has something to do with this. It this a pressure release area if to much gas gets in the bowl. Help. The other carb is working great.

waltesefalcon
08-29-2004, 11:43 PM
Where exactely on the carb is the hole? Is it low on the body near the bowl, and opposite the fuel line? Or is it higher on the body and towards the rear? Also if it runs fine while you have it plugged with your finger, I'd say just try making a plug and putting it in the hole.

tomgt6
08-30-2004, 10:16 AM
The hole is were the air cleaners mount at about 2 oclock. Just up from the stop that you mount the air cleaner can on to the carb.

waltesefalcon
08-30-2004, 12:02 PM
Really? That is bizare, I can't even think of a fuel passage along the front of the carb. I don't have a 150 handy so I can't take a peak at it, but what I would do if it were me is plug the hole and go on with my day. I'll try to get a 150 body today and see where the gas could posssibly be coming from.

VitSport6
09-01-2004, 04:28 PM
Hi Tom.
I think I may have ahd the same prob on the Sports 6, If memory serve's It's a stuck float, I had crud holding my float valve open, Just to see if I am talking about the same area, It is the large hole to bolt the AF onto...Right?
Good luck

tomgt6
09-02-2004, 10:18 AM
The large hole is at about 3 oclock that you mount the air cleaner canister into. This one is at about 2. I am pretty sure it is a float issue. I wanted to work on it last night but my 16 year old son needed help with the stereo in his car. He took out the old one and put in a new one and had the ground wire hooked to the illumination light wire so everytime he turned on the lights the radio went out and he would soon blow a fuse. Took about 2 hours to track down what wire was what. I hate electric issues. I hope tonight to look at this , I think I don't have the float adjusted right. Thanks for all the help. Tom

tomgt6
09-03-2004, 11:54 AM
Just to close this out I wanted to let you know what was the issue.
The float it has a small hole in it and would fill with gas. So it would never rise to turn off the gas flow and the extra gas then gets pushed out this hole. It is just a float issue in reality. Thank you all for the help. I learned alot about the 150 CD. It is funny they only made this one for the 1970 GT6. Why they don't change numbers on them I don't know but this one has a few differances then the other types. Have a good day all. Tom