PDA

View Full Version : GT6 gt6 tie rod lever



19_again
07-25-2009, 07:47 PM
I seem to get dumber and dumber. I apparently put the wrong side tie rod levers on when reassembling my front suspension, I found out when I went to put the left wheel assembly on and the hookup for the tie rod was facing the rear.
But since both sides are reversed, I'm pretty sure that I can just put them on the "wrong" sides and they should work. Am I wrong about that, it looks as if it might work.
I really don't want to take them apart for what will be the third time...

Andrew Mace
07-25-2009, 07:59 PM
Uh...not sure about this. I'm wondering if you might have entire vertical links and assemblies on the wrong sides as well? The RH vertical link has a RH thread for the trunnion, while the LH vertical link has a LH thread for the trunnion. Shouldn't be too hard to spot which is which, since the bottom of the RH trunnion should have a reduced diameter (compared to the other one).

19_again
07-26-2009, 07:46 AM
Well I think that you're right and that the entire assemblies are reversed. The dust plate cutouts for the tie rods are "properly" located in that they allow for the tie rod. I should have mentioned that the trunnions are new, in place and correctly turned back for free movement. That being the case, it seems to me that the only distinction is that the trunnion's movements (up and down) are really the only things that's actually "reversed", so that instead of the left going up as the wheel turns in one direction it would go down . And that I believe is the only "directional" aspect to the whole assembly. But I no longer assume.

It just occurred to me that I rebuilt one side at a time and did not mix up any parts, so it was already backwards apparently before I started. The trunnions were not marked as they are today, so the PO may have done the same thing and didn't realize it.