PDA

View Full Version : TR4/4A TR4 Ignition Warning Light



Kurtis
08-18-2004, 11:05 AM
Greetings...

The ignition warning light on my TR4 has never worked. I decided to try to track down the problem this evening. Using a voltmeter, I determined that I don't have a circuit connection between the control box (terminal D) and the lamp. There is a brown/yellow wire on the lamp base that disappears into my wiring harness, and then a single brown/yellow wire connected to terminal D on the control box (that I assume comes from the generator). The wiring diagram would seem to indicate two separate brown/yellow wires connecting at terminal D (one from the generator and one from the warning light). My wiring harness looks fairly unmolested from the lamp to the control box. Is
there supposed to be another wire?

BTW, when I do connect a length of wire from the lamp to the control box, it seems to function correctly (on at ignition on and low rpms, and off as rpms increase). The white wire from the light base to the ignition switch is in place and connected properly.

TIA

Kurtis

Webb Sledge
08-19-2004, 01:49 AM
I don't have Bentley manual or a wiring diagram for the TR4, but I assume you do (if not, you should get one. Very helpful...). Does the diagram show another wire? If so, there's your culprit.

Sorry I couldn't be of much help. I think I somehow managed to type a paragraph without saying anything.

piman
08-19-2004, 05:33 AM
Hello Kurtis,
do you have a WL terminal on the regulator?, if so the warning light (brown\yellow) wire should be connected there.

Alec

Kurtis
08-19-2004, 09:13 AM
I'm not sure what you mean by "WL" terminal. Regardless, I have it sorted out (sort of). I ended up running a new wire from the control box to the lamp base. I could find no evidence of a seperate wire branching off from the wiring harness near the control box, and I decided not to start unwrapping my harness and look for the mystery wire.

I'm now confident that there should be a seperate wire connecting to terminal D, I just can't figure out where the other end went. /ubbthreads/images/graemlins/smile.gif

Thanks,

Kurtis

piman
08-19-2004, 01:26 PM
Hello Kurtis,
WL is a terminal marking, as B, D, and F.
The diagram on my Triumph 2000 shows the warning light being connected to WL and not D. I don't know why there would be a seperate terminal but it would seem that there may be some fault created if you do use the D terminal.

Alec

Kurtis
08-19-2004, 03:16 PM
[ QUOTE ]
Hello Kurtis,
WL is a terminal marking, as B, D, and F.
The diagram on my Triumph 2000 shows the warning light being connected to WL and not D. I don't know why there would be a seperate terminal but it would seem that there may be some fault created if you do use the D terminal.

Alec

[/ QUOTE ]

Oh... okay. There is no WL terminal on the TR4 control box. The wiring diagram clearly shows it connected to the D terminal (there are two connection points - a large and a small spade connection). I just wish I knew where the heck the other end of the original wire from the warning lamp went. Like I said, it doesn't look like my wiring harness has been apart in that area... but who knows.

Thanks again for your reply.

Kurtis

Geo Hahn
08-19-2004, 06:22 PM
[ QUOTE ]
...I just wish I knew where the heck the other end of the original wire from the warning lamp went. Like I said, it doesn't look like my wiring harness has been apart in that area... but who knows...

[/ QUOTE ]

I have always thought that of Superman's powers, Xray vision would be the most useful to the TR owner.