PDA

View Full Version : Spitfire NEW ratcheting noise?(79 Spitfire)



myspitfire
04-29-2009, 12:50 PM
Hi guys;..help me understand :savewave:,i've developed what appears/sounds like a ratcheting(no clunks)just that noise comeing from the rear ON BRAKING,no pulling effects & i feel it in the brakes.The harder i brake the louder it gets.Kinda feels like a brake shoe is hanging up.Although i have a solid pedal w/no fading & no leaks.The emerg brake pulls strong & sets the rear brakes ok,i'm scratching my head & thought i'd get some extra opinions from the Tr doc's here :grouphug:.The first & BEST PLACE bar-none for advice.
TIA Ken&Whitelightning :bow:

kodanja
04-29-2009, 01:25 PM
when was the last time you had your drums turned?

Andrew Mace
04-29-2009, 01:41 PM
Have you pulled the drum(s) yet? I think you're on the right track in that it likely involves a shoe: perhaps retainer pin has fallen out, or the lining has separated partially from the shoe, or ????

Less likely, but perhaps the wheel cylinder isn't secure (retaining clips loose or gone)?

Guesses.... :confuse:

kodanja
04-29-2009, 01:50 PM
yeah I think your on the right track with the thought of retaining clips missing.

I just did my brake job, I found the I was missing 1 on the passengers side. the other two were very loose. that let the wheel cyld. slide around quite a bit...

pjsmetana
04-29-2009, 01:55 PM
Sounds to me like a cracked drum. I would definitely check that and make sure you have all the retaining clips.