PDA

View Full Version : carb question



kaidoSprite
07-05-2004, 07:51 PM
I'm pretty sure somthing is wrong with the front carb on my 68 sprite. It won't behave like it should. I've syncronized the butterfly's and am Idleing where I should be idleing. The problem is that the front carb won't hold the right air fuel mixture. No matter how rich I set it to it still acts like its running lean. The rear carb acts fine, when I slighty lift the piston at idle it revs up alittle then dies back down. While I hear almost no difference when I lift the front piston. Which leads me to believe something is wrong with my front carb's ablity to deliever fuel. Anyone have any idea what could be causeing this. /ubbthreads/images/graemlins/confused.gif I have recently replaced my jets and float needles.

Thanks

Trevor Jessie
07-05-2004, 08:26 PM
Sounds like a vacuum leak. Have you sprayed some carb cleaner aroung the manifold and the throttle shafts? (and listened for change in idle speed)

07-06-2004, 10:12 AM
I agree with Trevor - it sounds like you've got vacuum or air leaks. I have found these little engines with shared intake manifolds will run - at idle - on one carb, but just try to accelerate! Get the engine running at fast idle and carefully spray some carb cleaner at the throttle shafts and carb bodies where they meet the intake manifold. Any noticeable change in engine speed indicates an air leak that needs "fixin".

Tim C.

kaidoSprite
07-06-2004, 12:33 PM
I couldn't notice any difference when checking for leaks so I just took the carb off to better inspect it. Turns out The new jet I just put on was blocked up and leaking alittle, not at the fuel resivior but right at the bottom of the carb. The small plastic hose inside was kinda crimped so I think it was restricting fuel flow. Instead of waiting for another jet I fastened a small hose clamp around it which seems to have stoped the leak temporaily. It holds the right mixture now and wow what a difference.

aeronca65t
07-07-2004, 02:16 PM
kaidoSprite:

Glad you were able to sort out the problem...I was about to suggest the same thing as the other guys.
Is that your red Sprite in the picture? If so, is it a racer?

kaidoSprite
07-07-2004, 06:14 PM
nope thats not my sprite. I would love to race mine but finacially I don't think I could support it yet. I'm in colleage right now so money is tight. Heres a pic about a week after we got it to about "road worthy" condition. https://www.britishcarforum.com/ubbthreads/memberfiles/66866-003_0A.jpg