PDA

View Full Version : Fuel Pump?



captobvious
05-10-2002, 01:05 AM
I just replaced the fuel tank sending unit on my Sprite, which of course required the draining of the fuel tank. After refitting the tank the car started right up, ran for a bit, and then died. I now cannot get the car to start, to the point that the battery is quite low after trying for a while. I also noticed that the fuel pump is clicking a lot faster than usual. I'm assuming that this is all due to air in the fuel line and that I need to get fuel pumping through the system again. I know that fuel is not making it to the carbs because I have an inline fuel filter just before them and it is dry. How long should it take to get fuel pumping through again, and are there any tricks to speed up the process??

Any help would be greatly appreciated.

Thanks,
Mark

aeronca65t
05-10-2002, 08:05 AM
Shouldn't take more than a minute or so to start pumping. I'd guess you have an air leak or loose connection between the tank and the fuel pump....or, is the fuel pickup (in the tank) correctly postioned so that it's fully submerged in fuel?
Occcasionaly, with old pumps, they have a difficult time getting started.....if that's the case, you could try priming it with kerosene (and let the kero pump throught before hooking it up to the carbs).

captobvious
05-11-2002, 01:12 AM
Thanks for the reply and suggestions. With the nice day I was able to push it back into the driveway and inspect it and see that the flexible hose from the fuel pump wasn't tight enough around the fuel line to the tank to form a seal. 70 cents and a new hose clamp later and all is well!