PDA

View Full Version : Overdrive Fixed!



SCguy
04-24-2006, 11:26 AM
Well... actually it just started working. Some of you might remember that my overdrive would engage correctly, but not disengage until I turned off my car at which point I would hear a click and all would be back to normal. Now it's working as it should. Any thoughts... Do you suppose something was just clogged.

In any event, I'm just glad that it will be working for the Dixon, CA British car show!

TR4nut
04-24-2006, 12:21 PM
In case it happens again, here is a wild guess: maybe a bad relay switch that sticks on until the current goes off? This would make the overdrive switch and all the interlock switches useless.

One way to test is to stop in neutral while it is still misbehaving and keep everything running, then pull the connections off the relay - if it disengages, replace that relay.

Randy.

SpannerMan
04-24-2006, 12:32 PM
Not sure if it was covered in the earlier thread or if you already know, but just to be on the safe side - you don't want to back up - ever - if your overdrive is stuck engaged. There is a unidirectional clutch that can get destroyed by doing so. The first thing to check on the electrics is the functioning of the interrupter switches etc. just by turning on the ignition and moving the o/d switch and the gear lever and listening for the solenoid clicking at the appropriate times. I would disable the thing electrically personally if anything in that seems suspect, until such time as you have to rectify it. Pete

simpzimmer
04-24-2006, 02:24 PM
Mine will not engage on really cold mornings until the car warms up. I only tried once. I've really dreaded ever having to work on my overdrive, they look really complex...