PDA

View Full Version : Emission ???'s EGR; Anti Run-On valve etc...



boston
04-02-2006, 09:26 PM
Hi All,
Ran into this web site the other night and thought it was great. So I joined. I have a 74 1/2 Tr6. Bought it new. Not in the best of shape but still driving it evey summer (Michigan). Looks good from 50 yds..Pimento Red. Two years ago spent the winter rebuiding the front steering and suspension;back suspension;new redlines and brakes. Last year I rebuilt the Carbs. Messed around allot with the timing and air/fuel ratio. I burn 93 unleaded. It ran good but wonder if it could be better. Which brings me to my question. I don't have an EGR or Anti run-on valve on the car anymore (has been 10+ yrs).The evap cannister is still hooked up but everything else is plugged. The 74 1/2 was just before the air pump was "forced" on the car. Any suggestions or questions would be greatly appreciated.
Boston Bob

swift6
04-02-2006, 10:10 PM
Welcome to the mental ward. /ubbthreads/images/graemlins/jester.gif

Seriously, this is a great resource and a very friendly place.

My '72 TR6 was Pimento when it left Coventry. Now its not.

/ubbthreads/images/graemlins/cheers.gif

04-03-2006, 05:22 AM
Try running centrifugal advance instead of vacumn advance. Flip the timing over to about 8 degrees BTDC. Works for me.

Hotter coil, open a few gaps, basic tuning tricks.....

Not for everybody.


Bill

boston
04-03-2006, 08:25 AM
Hi Bill,
What do you mean by "open a few gaps"? I've read a few times where people have not used the vaccume from the carbs and blocked it off at the dist..Any thoughts on the emission crap?
Bob