PDA

View Full Version : Overdrive Quit!



Frank C.
04-14-2003, 10:17 AM
I was out with my '67 BJ8 yesterday and the OD just stopped engaging. Any ideas where to start looking?

Thanks in advance.

Dave Russell
04-14-2003, 12:49 PM
Frank,

See this earlier similar topic.
https://www.britishcarforum.com/cgi-bin/ultimatebb.cgi?ubb=get_topic&f=1&t=000839
D

Healey 100
04-14-2003, 01:14 PM
Frank:

My experience is that failure for the OD to engage is usually an electrical problem. Either the solenoid internal contacts are worn and dirty (very, very common) or there is a failure in the relays, wiring, or control switches that power the solenoid. If the problem is intermittant, I think the solenoid contacts are probably the problem. These contacts must be clean to give the solenoid enough oomph to engage the OD.

Still, the linkage from the solenoid to the OD might be improperly adjusted, though this is doubtful because I assume the unit worked OK before. Also, make sure there is enough oil in the unit.

Unfortunately, repairs will require exposing the transmission. I usually do that and drive the car and manually activating the OD with the lever on the right side of the OD. If the OD engages, that indicates the unit is mechanically OK, and you can focus on finding the electrical problem.

Bill

Frank C.
04-15-2003, 12:52 PM
Thanks for the advice and links. I did some simple tests last night and found out at least the relay is clicking on okay. I took it for a ride and found out that the problem is intermittant! I'll work on it more this weekend.

Thanks again.

Frank