PDA

View Full Version : Thanks button error



John Turney
09-13-2019, 10:57 AM
I tried to give a "Thanks" to a couple of posts in the Randy Forbes thread in the Austin Healey forum and I get:


[] operator not supported for strings on line 182 in /home/bcf/public_html/bcf/includes/functions_post_thanks.php
#0 /home/bcf/public_html/bcf/includes/functions_post_thanks.php(137): fetch_thanks('1120552', '', false)
#1 /home/bcf/public_html/bcf/post_thanks.php(64): thanked_already(Array)
#2 {main}

What gives?

Basil
09-13-2019, 10:59 AM
I tried to give a "Thanks" to a couple of posts in the Randy Forbes thread in the Austin Healey forum and I get:



What gives?

Well, I think you just found an issue with a newer version of PHP I recently upgraded to for the forum. PHP is the script language that basically handles all the behind the scenes actions for anything that you do on the forum. (For example, even reading this thread/post, if you look up in the address bar you will see it is using a script called "show thread.php" and PHP is the "language" that interprets all the commands in that script. This forum software was developed back when version 5.6 (or maybe older) was the latest version. There have been many updates to PHP since then. I recently updated the PHP version running on this site to version 7.1, which is not the latest, but is supposed to be the newest that this forum software will run on. While it seems that basic forum is running ok on 7.1, that "thank you" feature is not stock forum software, but rather a 3rd party plugin to "add: that capability to the forum. Apparently, that plugin doesn't like version 7.1. I just backed off one version to 7.0 and the thanks button seems to be working. Try it now and see of it works for you.

PS: Note that I moved your question to a new, separate thread (You had posted as a reply to my thread about the help forum). I think I'm going to lock that thread. Better to post questions as new topics, with descriptive titles.

Basil
09-13-2019, 11:14 AM
Update: I determined the issue in the "Thanks script" that was causing a problem with PHP 7.1 and have modified that script so that now, the "thanks script" should be working with PHP 7.1. Let me know if you have any other problems with it.

Basil