PDA

View Full Version : ZS Flooding ??????



lees74tr6
06-18-2005, 02:26 AM
I am new here. I have a continous problem with my 74 tr6. After doing a complete carb rebuild on zs carbs I believe I still have a float problem. Both floats are set at 16.5 - 17mm. vehicle starts perfectly if on level ground or pointing down hill (will not start uphill). Should I reduce the float levels or increase? Please help. Thank you.

TR4
06-18-2005, 08:42 AM
I rebuilt a set of ZS's on my TR4 and started with 17mm then went to 20mm for less fuel in the bowl and 15mm for more to see if the car would behave any differently. I ended up leaving them at 15mm and I'm very pleased with that setting. I talked with a specialist and he told me every set of carbs would have an optimum setting but there is a range of 2 to 4mm that the car will run very good at. One other thing you might want to check is your fuel pressure. There might not be enough to feed uphill.

lees74tr6
06-18-2005, 11:16 AM
Thanks for the help. I replaced the fuel pump 2 weeks ago. The pressure test shows 3.5lbs to the front carb. The up hill discription I posted is a verry slight grade maybe 3%. I'll try moving the flots up to 18mm to 18.5 mm for less gas. I have repaced almost every external item ecept the distubutor and Strater motor on this last rebuilt. However this hard starting problem has been difficult to fix. I can remove these carbs with my eyes closed. This may be the 5th or sixth time in the past week. What a labor of love this car has been. The ignition has been tested and confirmed in excelent condition and every thing is working properly, Every clue keeps us coming back to the carbs.