PDA

View Full Version : TR2/3/3A 1961 Triumph TR3A - Light issues...likely issue?



spineguru
07-23-2015, 12:41 PM
Been a while since i have been on here... TR3 has been purring along real well, but last night I had to move it after dark and noticed I have some light issues. Some are working, some are not. Based on the below information, can someone give me their thoughts on where to look for the issue?

Working: Head lights, brights, brake lights, turn indicators
Not working: Tail lights (brake lights are, but not the tail lights), dash lights

Thanks in advance for your thoughts.

TomMull
07-23-2015, 12:54 PM
Fuses OK?
Tom

Lukens
07-23-2015, 01:30 PM
Your front parking, rear tail lamps, license plate, and dash lights all come directly from the light switch. Your headlights come from the same switch and they work, that tells me the switch is getting juice. The fact that your taillights and dash lights don't come on suggests the problem is in the switch. Jumper the red wire to the blue/brown wire at back of switch to confirm (lights should come on).

Russ

6TTR3A
07-23-2015, 05:16 PM
deleted

sqbsprite
07-23-2015, 09:02 PM
Usually when I have random lights not working, I find it is corrosion on the bulb and socket contact. Remove the bulb and clean the contact on the socket and the solder boss on the bulb. My side marker lights on my TR6 went out just this week and they both had this problem. One had been that way for awhile and I just had not checked it.

spineguru
07-23-2015, 09:24 PM
Thanks for the suggestions.... ended up being a bit of a rookie request on my part. Just a loose wire issue. I just could not see it well enough last night. had to be a bit of a contortionist, but I got everything tightened back up. All lights are functional again.

Thx!