• warwick-steve

    There is no available content written by warwick-steve
  • Recent Articles

  • Recent Forum Posts


    Re: 1956 Nasty Boy

    Here they are:

    "I owned this car in 2012. The car was running and driving then, with minimal front brakes only. The car came from the

    HealeyRick Today, 06:10 AM Go to last post

    Re: 1956 Nasty Boy

    there is more info on facebook...race and modified healeys and mg midgets...i don't know how to post a link! interesting comments there.

    maxwedge5281 Today, 05:58 AM Go to last post

    Re: All the coolant in the wrong place

    I'd be inclined to agree -- I, too, suffered the dreaded blanking plug failure on my 1275. Fortunately, I caught it before the damage got out of hand

    SaxMan Yesterday, 11:04 PM Go to last post

    Re: New Old Member...sort of.

    Welcome aboard!

    I own a '69 Sprite. I really didn't know squat about cars when I bought it. The fine people on this forum have been an

    SaxMan Yesterday, 11:01 PM Go to last post

    Motorweek TBM Avenger Clip

    I recently found this clip from an old episode of Motorweek featuring Jack Kosko and the first Avenger he restored. I met Jack about 3 years and change

    SaxMan Yesterday, 10:58 PM Go to last post
  • Recent Blog Posts

    Ronald Roy

    Hello, new member here

    I have a 1963 Sprite which I owned in the 70s and 80s , sold it (bad day)
    And recently found and bought it back from the internet in poor shape but repairable. Trying to get it registered but the...

    Ronald Roy 02-28-2018 05:18 PM
  • Twitter