• SU H6 Carburetor Will Not Decelerate

    I have a 1962 Triumph TR3B with SU H6 carbs. After a recent disassembly, cleaning and reassembly of the carbs the RPM would not return to idle after a load. It continued at an accelerated rate whether under load or at a stop - racing. Only by "goosing" the throttle with the accelerator did the RPM drop, but still not to the proper idle - 600 - 900 RPM (or anywhere close to it).

    I checked that each throttle plate was centered in the barrel, that they closed easily and no "daylight" around the edges of the plate. The carb pistons went up and down easily, dash pots properly filled with the right oil, jet needles centered in the jets and not binding. No vacuum leaks at gaskets.

    After much investigation I discovered that I had two problems: (1) the throttle return springs were not set in high enough torsion and (2) the coupling assemblies on the connecting rod were slipping under load. I could not detect slippage at curb idle by manually manipulating the throttle linkage but under load it seems the connection to #2 carb slipped. This allowed at least #2 carb to remain with an open throttle plate vs. #1 carb. The coupling was just tight enough to respond to "goosing" the accelerator but having slipped it was now out of balance. Also, the shafts are made of brass and over time will score from the connectors, also contributing to possible slippage.

    By torsioning the springs another half turn and tightening the connecting couplings I now have proper carburation. (Note: I also have a slight vacuum leak on #1 at the throttle shaft due to wear. This affects balance and fuel consumption but was not the cause of the "racing" problem)

    I hope this helps someone. I couldn't find a similar discussion anywhere.

    I have attached the Moss plate showing the connectors (66) and the springs (77):

    https://mossmotors.com/triumph-tr2-3...retors-su-h6-1
    Comments 1 Comment
    1. karls59tr's Avatar
      karls59tr -
      Thanks for the info. I've been battling this problem for awhile. Usually had to goose the throttle to bring the idle down but never WOT like you experienced.
  • Recent Articles

    RLN

    TR-3 NOS parts

    New Old Stock, in Stanpart boxes, overriders and bumperettes. $350.00 or BO

    Lucas License plate light/ NOS boxed. $75.00 or BO... read more
    RLN 03-27-2020, 12:01 AM
  • Recent Forum Posts

    Bob Claffie

    Re: Steering not right

    Another unlikely scenario, is it possible that the steering column itself has suffered a twist in the accident ?

    Bob Claffie Today, 04:25 PM Go to last post
    healey106

    Re: A Toast to John Wheatley - A Call for Action

    John Wheatley was certainly a GREAT Healey person. A True One of a KIND!!!! He set my wife and I up for a FANTASTIC WEEKEND AT THE HEALEY INTERNATIONAL

    healey106 Today, 04:17 PM Go to last post
    Gliderman8

    Re: 75 TR 6 seat track location

    I have attached a pic of a floor panel and circled in WHITE the caged nut for the seat rails.
    Hopefully you will be able to see the nut welded to

    Gliderman8 Today, 04:08 PM Go to last post
    Kagol1

    Old owner - New Forum!

    I've had my '75 TR6 since 1982. Never any major problems, but a lot of maintenance along the way. Bought it red, but returned it to original Mimosa

    Kagol1 Today, 03:53 PM Go to last post
    Barefoot

    Re: Healey assembly line - engine installation

    I just noticed that the bumper is covered with something. I didn't see that when I read the article.

    Barefoot Today, 03:28 PM Go to last post
  • Recent Blog Posts

    RLN

    TR-3 NOS parts

    RLN 03-27-2020 12:05 AM
    EWD

    TR6 gauge bezels

    Just finished refurbishing my 74 gauges and the bezel (52mm) to one of the smaller gauges (fuel, but they are all the same) has a broken tab.
    Iím looking for a replacement bezel (chrome with black...

    EWD 03-26-2020 10:31 AM
  • Twitter