PDA

View Full Version : Elan +2 -- Headlights don't come on for 3 minutes



Hegg
11-16-2004, 11:09 PM
Another question! Don't hate me!

I've been trying to get my headlights working on my 1970 Elan +2, but they never turn on. The other day I discovered suddenly that they were on, even though I wasn't checking. I was working on the tail lights at the time (burnt out bulb) and had accidentally left the headlights "on".

Upon further testing, I've found that if I turn the headlights "on" they won't come on for 3 or 4 minutes after the switch is on. I just leave the switch on for 3 minutes and BAM they turn on.

My only suspicion is the relays -- does that make sense? I guess it could be the headlight switch itself, but that seems less likely to me.

Oh, and when they do finally come on, I hear the relay *click*.

Thanks!

Hegg

TypeRboy
12-02-2004, 08:52 PM
Oh it sounds like the relay for sure. You can unclip the wiring and bypass the relay to check for sure, same for the switch. Pretty simple fix by the sounds of it...

On my car there was also a couple of switches that were attached with small springs to the h/l buckets. When the lamps rotated up the springs pulled these switches on, I assume to prevent the lights from turning on when the lamp buckets were down. I removed them ( one less electrical thing to worry about ) with no operating problems so far.

And don't worry about asking questions.. If it wasn't for every body's knowledge that I have tapped into over the years, my car would still be in boxes!

Hegg
12-11-2004, 08:44 PM
Well I found the problem to be in the headlight switch. Oddly enough, the loose connection (are any connections tight when Lucas is around?) would "tight" itself a few minutes after I turned on the headlights.

The bad news is that I busted the light switch while working on it. Now I gots to buy a new one or something. Any idea where to source one? It's the dual-vacuum line type.