PDA

View Full Version : Browser script question



NutmegCT
03-31-2008, 12:05 PM
(moved from Help topic)

Question: until two days ago, if I want to use File Manager, I'd just click it and get the File Manager window.

Now, if I click the link, I still see "Run script "void(0)" under the link, and the focus still changes from the text window to the File Manager link, but nothing else happens. No window opens. The page source shows the full script, but it seems to have no effect.

File Manager and Poll Manager work fine in Firefox and Camino, but not in the browser I've used all year - Safari 3.1.

Any thoughts? I've cleared cache, cleared cookies, and even completely reset Safari. Logged back in, but still no luck.

Thanks.
Tom

Dave Russell
03-31-2008, 04:58 PM
I'm in Safari 3.1. Will try attaching a pic.
D
PS - it worked for me.

NutmegCT
03-31-2008, 05:18 PM
Thanks Dave.

Say - are you using Safari on a Mac, or on a PC? I didn't have this trouble until (I think) I installed the recommended Security Update 2008-2 on OSX, or the Safari 3.1 update. Naturally, both of these were done in the last couple days.

Really strange that all the browser scripts have been "disabled", but only in Safari.

Tom

Dave Russell
03-31-2008, 06:17 PM
Hi Tom,
IMac/Intel system 10.4.11.
I'm presently running Safari 3.1. I have not installed Security update 2008-002.

Now you have me spooked. Maybe I won't do this update? Can you go back to the earlier version & see what happens?
D

NutmegCT
03-31-2008, 06:24 PM
Thanks Dave. I've been googling the Safari 3.1 update, and the SecUpd 2008-02. So far no obvious problems are mentioned - but it is interesting that this javascript "issue" occurs on sites other than BCF, but only in my Safari 3.1.

Removing a SecUpd is a total pain, but I'm thinking it's a Safari problem, as 3.1 is supposed (!) to handle javascript more "efficiently and securely". And again, the SecUpd would affect more than Safari.

Sure wish I could find a 3.0.4 install and "backdate" my 3.1. But I haven't found a single "previous versions" anywhere - even on apple.com

Onward through the fog!
Tom

Dave Russell
03-31-2008, 06:30 PM
See my revised note above. I have Safari 3.0.4 if it would help. I think the problem might be in the 2008-002 part though.
D