PDA

View Full Version : TR6 TR6 Heater Problems



A. Salnick
03-24-2003, 03:24 PM
I recently purchased a 69 tr6. It has turned into a great daily driver except for one problem, the heater. The heater does a terrible job of warming the car and defrosting the windshield. My old Land Rover is far warmer. Granted the soft top doesn’t seal perfectly, but even at low speeds the car never really warms up all that much. The defroster has very weak airflow. The dash vents are better, but the blow only moderately warm air. Just enough to keep it warmer than the outside but not comfortably warm. I checked the heater flap adjustment on the heater box and it appears to be working fine. Next I back flushed the core with a garden hose for 20 mins. This made little to no difference. A new thermostat also had little effect. The heater hoses warm up, but the air in the core just doesn’t seem to take the heat. Is the heater in the tr6 really this poor? Has anyone else had similar problems? Anyway, thanks for your time.

Steven
03-24-2003, 05:43 PM
there could be a couple of things to check. First make sure the cable that operates the heater valve isn't slipping due to a loose screw at the point where it attatches to the valve. Then check to make sure your heater hoses aren't reversed. The worst of all scenarios would be a plugged heater core. Pray it isnt that. images/icons/cool.gif

A. Salnick
03-24-2003, 05:46 PM
I actaully have the valve wired open. The cable was broken when I got the car. Also, the hoses are for sure plumbed correctly. Is this heater pretty good in most people's tr's?

TRED
03-25-2003, 01:31 PM
Try opening the little scoop on the cowl. I have heard it needs to be open to get good heat.

Rick O.
03-25-2003, 02:40 PM
Well, if both heater hoses are hot, then flow through the core isn't an issue. I bet you haven't closed the dash AND footwell eyeball vents (there are 4 in all). Put the flap control in the "defrost" postion. You should have good flow to the windscreen with the fan on and at-speed with the fan off. If not, there's debris clogging the heater core fins and/or supply ducts to the windscreen. That'll take some effort to disassemble and clear up.

Good luck. graemlins/crazyeyes.gif

MDCanaday
04-01-2003, 01:51 AM
Rick is dead right on this one, I think derbis and I smell a mouse!! The little bastards love to get into heaters and make nests. Its no fun but you had better clean it out asap, the mouse wastes will corrode the core in time, or even present a fire hazard(there will be chewed wires!)
MD(mad dog)