PDA

View Full Version : TR6 TR6 Oil Pressure issues



howie18
01-09-2001, 01:21 PM
Dear All,

I just picked up a '73 TR6, which I love. It is in pretty good shape. When I got it several weeks ago, the oil pressure was fine, about 40 psi at idle. Now, it has fallen to about 10 psi at idle and does not rise significantly at higher rpms.

Are there any "known" or "common" problems that might cause this or is there anything in particular I should look at first?

Thanks in advance for any help in this matter.

Howie

Basil
01-13-2001, 07:00 PM
Originally posted by howie18:
Dear All,

I just picked up a '73 TR6, which I love. It is in pretty good shape. When I got it several weeks ago, the oil pressure was fine, about 40 psi at idle. Now, it has fallen to about 10 psi at idle and does not rise significantly at higher rpms.

Are there any "known" or "common" problems that might cause this or is there anything in particular I should look at first?

Thanks in advance for any help in this matter.

Howie

I'm not that familiar with the TR6, but if it's anything like a Jag EType, and has an oil pressure relief valve, make sure that is in good working order. Of course make sure you have good clean oil and filter too. Any major leaks?

hlub34a
01-15-2001, 01:35 AM
[QUOTE]Originally posted by howie18:
[B]Dear All,

I just picked up a '73 TR6, which I love. It is in pretty good shape. When I got it several weeks ago, the oil pressure was fine, about 40 psi at idle. Now, it has fallen to about 10 psi at idle and does not rise significantly at higher rpms.

//////
First..what changed other than the oil pressure? did you change oil? Do you have the original cannister filter or a spin-on unit? How is the oil consumption? Have you added any?

I have a very original 73. I run 20/50 Valvoline and the pressure is about 60 lbs. After it's warmed up the pressure goes to about 20 at idle, but goes back up at road speed.

It could be that the gauge is bad. Is there any way you could put another gauge on to check?



------------------